CVE-2026-33026: 0xJacky nginx-ui · Cleartext Storage of Sensitive Information
Affects 0xJacky nginx-uiSource CVE Database V5
Not known to be exploited · CVSS 9.4 Critical : upgrade to 2.3.4 as a priority.
Data as of 30 Oct 2026, 06:59 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.3.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 30 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade nginx-ui and 0xjacky/nginx-ui to 2.3.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| 0xJackynginx-ui | Affected
| Fixed in
|
GitHub0xjacky/nginx-uipkg:github/0xjacky/nginx-uiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the 0xJacky nginx-ui to version 2.3.4 or later, where this vulnerability has been officially patched. Applying this update will remediate the cleartext storage and backup validation issues. No additional mitigation is required if the patch is applied.
Description
CVE-2026-33026 is a critical vulnerability in the 0xJacky nginx-ui web user interface for the Nginx web server. Versions prior to 2.3.4 have a flaw in the backup restore mechanism that allows attackers to tamper with encrypted backup archives and inject malicious configuration during restoration. This issue involves cleartext storage of sensitive information and improper validation of backup archives. The vulnerability has been patched in version 2.3.4. The CVSS 4.0 score is 9.4, indicating a critical severity level.