Skip to main content
VulnerabilityPublished

CVE-2026-33031: 0xJacky nginx-ui · Improper Access Control

Affects 0xJacky nginx-uiSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 2.3.4 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nginx-ui and 0xjacky/nginx-ui to 2.3.4.

Affected software

ProductAffectedFixed in
0xJackynginx-uiAffected
  • <2.3.4
Fixed in
  • 2.3.4
GitHub0xjacky/nginx-uipkg:github/0xjacky/nginx-uiOther threatsAffected
  • <2.3.4
Fixed in
  • 2.3.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade nginx-ui to version 2.3.4 or later, where this vulnerability is patched. There is no official remediation level stated beyond this version upgrade. Until upgrading, administrators should be aware that disabling accounts does not immediately revoke token-based access.

Description

CVE-2026-33031 is an improper access control vulnerability in 0xJacky's nginx-ui versions prior to 2.3.4. The issue allows users who have been disabled by an administrator to continue using previously issued API tokens until those tokens expire. This means that disabling a compromised account does not immediately revoke access, enabling an attacker with a stolen JWT to keep reading and modifying protected resources. Additionally, since tokens can be used to create new accounts, the disabled user may maintain privileges indefinitely. Version 2.3.4 addresses this vulnerability.

References

Community reviews

Loading reviews…