CVE-2026-33130: louislam uptime-kuma · PHP Remote File Inclusion
Affects louislam uptime-kumaSource CVE Database V5
Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.2.1 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 20 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade louislam uptime-kuma to 2.2.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| louislamuptime-kuma | Affected
| Fixed in
|
GitHublouislam/uptime-kumapkg:github/louislam/uptime-kumaOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Upgrade Uptime Kuma to version 2.2.1 or later, where the vulnerability is fully patched.
- Review and restrict user privileges to minimize the risk of attackers having the required privileges to exploit this vulnerability.
- Implement strict input validation and sanitization on any user-controllable inputs that influence template rendering or file inclusion paths.
- Monitor logs for suspicious file access patterns, especially attempts to include absolute paths or access sensitive files like /etc/passwd.
- Employ network segmentation and firewall rules to limit access to Uptime Kuma instances only to trusted users and systems.
- Conduct regular security audits and penetration testing focusing on template injection and file inclusion vulnerabilities.
- If upgrading immediately is not possible, consider temporarily disabling or restricting features that allow template customization or file inclusion.
- Educate developers and administrators about secure template engine usage and the risks of improper file inclusion.
Description
CVE-2026-33130 is a medium-severity vulnerability in Uptime Kuma versions 1.23.0 through 2.2.0 that allows attackers with limited privileges to read arbitrary files on the server. The issue arises from improper control of filename inclusion in the LiquidJS template engine, specifically in the require.resolve() fallback mechanism, which lacks containment checks for unquoted absolute paths. This flaw enables remote file inclusion (RFI) attacks, potentially exposing sensitive server files such as /etc/passwd. The vulnerability does not require user interaction but does require some level of privileges (PR:L). It was fixed in version 2.