CVE-2026-33158: craftcms cms · Insecure Direct Object Reference
Affects craftcms cmsSource CVE Database V5
Not known to be exploited · CVSS 4.9 Medium : upgrade to 5.9.14 or 4.17.8 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.14, 4.17.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 24 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade craftcms cms to 5.9.14 or 4.17.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| craftcmscms | Affected
| Fixed in
|
| craftcmscms | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade Craft CMS to versions 4.17.8 or 5.9.14 or later, where the authorization bypass has been fixed. Until upgrades can be applied, administrators should restrict access to the assets/edit-image endpoint to trusted users only and consider implementing additional access controls at the web server or application firewall level to block unauthorized assetId parameters. Conduct an audit of user privileges to ensure that only necessary users have authenticated access to the CMS, minimizing the risk from low-privileged accounts. Monitor access logs for unusual or unauthorized attempts to access asset content via the vulnerable endpoint. If possible, temporarily disable or restrict the use of image editing or preview features that invoke the vulnerable endpoint. Additionally, review and enhance overall access control policies and implement defense-in-depth measures such as network segmentation and strong authentication to reduce the attack surface. Finally, educate users about the importance of safeguarding credentials to prevent exploitation by malicious actors.
Description
CVE-2026-33158 is a medium-severity authorization bypass vulnerability in Craft CMS versions from 4.0.0-RC1 up to but not including 4.17.8, and 5.0.0-RC1 up to but not including 5.9.14. A low-privileged authenticated user can exploit this flaw by calling the assets/edit-image endpoint with an arbitrary assetId, allowing them to access private asset content without proper authorization checks.
References
- github.com/craftcms/cms/security/advisories/GHSA-3pvf-vxrv-hh9c (opens in a new tab)
- github.com/craftcms/cms/commit/7290d91639e5e3a4f7e221dfbef95c9b77331860 (opens in a new tab)
- github.com/craftcms/cms/releases/tag/4.17.8 (opens in a new tab)
- github.com/craftcms/cms/releases/tag/5.9.14 (opens in a new tab)