CVE-2026-33227: Apache ActiveMQ Client · Improper Input Validation for Resource Loading
Affects Apache ActiveMQ ClientSource CVE Database V5
Not known to be exploited · CVSS 4.3 Medium : upgrade to 6.2.2 or 5.19.3 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.2, 5.19.3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache ActiveMQ Client and Apache ActiveMQ Broker and Apache ActiveMQ All and Apache ActiveMQ Web and Apache ActiveMQ and org.apache.activemq/activemq and Apache Software Foundation/org.apache.activemq:activemq-client and Apache Software Foundation/org.apache.activemq:activemq-broker and Apache Software Foundation/org.apache.activemq:activemq-all and Apache Software Foundation/org.apache.activemq:activemq-web and Apache Software Foundation/org.apache.activemq:apache-activemq and org.apache.activemq/activemq-client and org.apache.activemq/activemq-broker and org.apache.activemq/activemq-all and org.apache.activemq/activemq-web to 6.2.2 or 5.19.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache ActiveMQ Client | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ Client | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ Broker | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ Broker | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ All | Affected
| Fixed in
|
| Apache Software FoundationApache ActiveMQ All | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache ActiveMQ components to version 5.19.4 or 6.2.3, which fully fix the vulnerability including Windows path separator issues. Versions 5.19.3 and 6.2.2 provide partial fixes limited to non-Windows environments. Patch status is confirmed by the vendor advisory embedded in the description. No other mitigations are indicated.
Description
Improper validation and restriction of a classpath path name vulnerability in Apache ActiveMQ Client, Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ Web, Apache ActiveMQ. In two instances (when creating a Stomp consumer and also browsing messages in the Web console) an authenticated user provided "key" value could be constructed to traverse the classpath due to path concatenation. As a result, the application is exposed to a classpath path resource loading vulnerability that could potentially be chained together with another attack to lead to exploit. This issue affects Apache ActiveMQ Client: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Broker: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ All: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ Web: before 5.19.3, from 6.0.0 before 6.2.2; Apache ActiveMQ: before 5.19.3, from 6.0.0 before 6.2.2. Users are recommended to upgrade to version 5.19.4 or 6.2.3, which fixes the issue. Note: 5.19.3 and 6.2.2 also fix this issue, but that is limited to non-Windows environments due to a path separator resolution bug fixed in 5.19.4 and 6.2.3.