Skip to main content
VulnerabilityPublished

CVE-2026-33267: Apache Traffic Server · Improper Input Validation

Affects Apache Traffic ServerSource CVE Database V5

0

Not known to be exploited · CVSS 10.0 Critical.

Data as of 28 Oct 2026, 05:11 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Traffic ServerAffected
  • >=9.2.0 <=9.2.14
  • >=10.1.0 <=10.1.3
Fixed in–

AI-suggested

Users should upgrade Apache Traffic Server to version 9.2.15 or 10.1.4 to remediate this vulnerability. Patch status is confirmed by the vendor's version recommendations. No other mitigation steps are indicated.

Description

CVE-2026-33267 is a critical improper input validation vulnerability in Apache Traffic Server affecting versions from 9.2.0 through 9.2.14 and 10.1.0 through 10.1.3. The vulnerability allows an attacker to cause a complete compromise of confidentiality and integrity without requiring user interaction or privileges. Upgrading to versions 9.2.15 or 10.1.4 addresses this issue.

References

Community reviews

Loading reviews…