CVE-2026-58183: Apache Traffic Server · Improper Input Validation
Affects Apache Traffic ServerSource CVE Database V5
Not known to be exploited · CVSS 5.9 Medium · fixed in 9.2.15 : update Apache Traffic Server when convenient.
Data as of 28 Oct 2026, 05:11 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.2.15
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Traffic Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache Traffic Server to version 9.2.15 or 10.1.4 or later to remediate this vulnerability. No other mitigations or temporary fixes are indicated. Patch status is confirmed by the vendor advisory recommending these versions.
Description
The Apache Traffic Server prefetch plugin can crash when processing attacker-influenced input. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.