Skip to main content
VulnerabilityPublished

CVE-2026-33344: dagu · Path Traversal

Affects daguSource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.1 High : upgrade to 2.3.1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.3.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade dagu and dagu-org/dagu to 2.3.1.

Affected software

ProductAffectedFixed in
dagu-orgdaguAffected
  • >=2.0.0 <2.3.1
Fixed in
  • 2.3.1
GitHubdagu-org/dagupkg:github/dagu-org/daguOther threatsAffected
  • >=2.0.0 <2.3.1
Fixed in
  • 2.3.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade dagu to version 2.3.1 or later, where the vulnerability is fully patched. Until upgrade is possible, restrict network access to the dagu web interface using firewalls or VPNs to limit exposure to trusted users only. Implement strict authentication and authorization controls to minimize the risk of unauthorized access. Conduct a thorough audit of existing DAG files and related directories to detect any unauthorized modifications or suspicious activity. Monitor logs for unusual API requests containing encoded path traversal sequences such as %2F. Employ web application firewalls (WAFs) with custom rules to detect and block path traversal attempts targeting the {fileName} parameter. Educate administrators and developers about secure coding practices, emphasizing consistent input validation across all API endpoints. Finally, integrate vulnerability scanning and penetration testing into the development lifecycle to detect similar issues proactively.

Description

CVE-2026-33344 is a high-severity path traversal vulnerability in the dagu workflow engine versions 2.0.0 up to but not including 2.3.1. The flaw arises because several API endpoints (GET, DELETE, RENAME, EXECUTE) fail to properly validate the {fileName} URL parameter, allowing attackers to use encoded forward slashes (%2F) to traverse directories outside the intended DAGs directory. This can lead to unauthorized access and modification of files, impacting confidentiality and integrity. The vulnerability requires network access and low privileges but no user interaction. It was patched in version 2.3.

References

Community reviews

Loading reviews…