Skip to main content
VulnerabilityPublished Updated

CVE-2026-3338: AWS-LC · (Improper Verification of Cryptographic Signature)

Affects AWS-LCSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 1.69.0 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.69.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade AWS-LC and aws/aws-lc to 1.69.0.

Affected software

ProductAffectedFixed in
AWSAWS-LCAffected
  • >=1.41.0 <1.69.0
Fixed in
  • 1.69.0
GitHubaws/aws-lcpkg:github/aws/aws-lcOther threatsAffected
  • <1.69.0
Fixed in
  • 1.69.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

AWS manages remediation for this vulnerability in its cloud services, so customers using AWS services do not need to take action. Applications using AWS-LC directly should upgrade to AWS-LC version 1.69.0, which contains the fix for this issue. Patch status is confirmed as available. Refer to the vendor advisories at https://aws.amazon.com/security/security-bulletins/2026-005-AWS/ and https://access.redhat.com/security/cve/CVE-2026-3338 for detailed guidance.

Description

Improper signature validation in PKCS7_verify() in AWS-LC allows an unauthenticated user to bypass signature verification when processing PKCS7 objects with Authenticated Attributes. Customers of AWS services do not need to take action. Applications using AWS-LC should upgrade to AWS-LC version 1.69.0.

References

Community reviews

Loading reviews…