CVE-2026-33515: squid · Out-of-bounds Read
Affects squidSource CVE Database V5
Not known to be exploited · CVSS 6.9 Medium : upgrade to 7.5 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 26 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade squid and squid-cache/squid to 7.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| squid-cachesquid | Affected
| Fixed in
|
GitHubsquid-cache/squidpkg:github/squid-cache/squidOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2026-33515, organizations should upgrade Squid to version 7.5 or later, where the vulnerability is patched with proper input validation. If immediate upgrade is not feasible, consider disabling ICP support by setting icp_port to zero, effectively removing the vulnerable code path. Since icp_access rules do not prevent exploitation, relying on access control lists to block ICP queries is insufficient. Network-level filtering can be employed to block ICP traffic (UDP port 3130 by default) from untrusted sources to reduce exposure. Monitoring Squid logs for unusual or malformed ICP requests may help detect attempted exploitation. Additionally, conduct an inventory of Squid deployments to identify those with ICP enabled and prioritize patching or configuration changes accordingly. Regularly review Squid configurations and update to supported versions to minimize exposure to known vulnerabilities.
Description
Squid is a caching proxy for the Web. Prior to version 7.5, due to improper input validation, Squid is vulnerable to out of bounds read when handling ICP traffic. This problem allows a remote attacker to receive small amounts of memory potentially containing sensitive information when responding with errors to invalid ICP requests. This attack is limited to Squid deployments that explicitly enable ICP support (i.e.configure non-zero `icp_port`). This problem cannot be mitigated by denying ICP queries using `icp_access` rules. Version 7.5 contains a patch.
References
- github.com/squid-cache/squid/security/advisories/GHSA-84p4-hcx7-jj7c (opens in a new tab)
- github.com/squid-cache/squid/pull/2220 (opens in a new tab)
- github.com/squid-cache/squid/pull/2220 (opens in a new tab)
- github.com/squid-cache/squid/commit/8138e909d2058d4401e0ad49b583afaec912b165 (opens in a new tab)
- openwall.com/lists/oss-security/2026/03/25/4 (opens in a new tab)