Skip to main content
VulnerabilityPublished

CVE-2026-33523: Apache HTTP Server · HTTP Response Splitting

Affects Apache HTTP ServerSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium · fixed in 2.4.67 : update Apache HTTP Server when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 37% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.67
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache HTTP ServerAffected
  • >=2.4.0 <=2.4.66
Fixed in–
Apacheapache/httpdpkg:rpm/apache/httpdOther threatsAffected
  • <=2.4.66
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache HTTP Server to version 2.4.67 or later, where this vulnerability is fixed. No other mitigation guidance is provided. Patch status is confirmed by the vendor advisory recommending this upgrade.

Description

HTTP response splitting vulnerability in multiple Apache HTTP Server modules with untrusted or compromised backend servers. This issue affects Apache HTTP Server: from through 2.4.66. Users are recommended to upgrade to version 2.4.67, which fixes the issue.

References

Community reviews

Loading reviews…