Skip to main content
VulnerabilityPublished

CVE-2026-33611: PowerDNS Authoritative · Integer Overflow or Wraparound

Affects PowerDNS AuthoritativeSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 5.0.4 or 4.9.14 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.0.4, 4.9.14
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Authoritative and pdns to 5.0.4 or 4.9.14.

Affected software

ProductAffectedFixed in
PowerDNSAuthoritativeAffected
  • >=5.0.0 <5.0.4
Fixed in
  • 5.0.4
PowerDNSAuthoritativeAffected
  • >=4.9.0 <4.9.14
Fixed in
  • 4.9.14
GitHubpdnspkg:github/pdnsOther threatsAffected
  • >=5.0.0 <5.0.4
  • >=4.9.0 <4.9.14
Fixed in
  • 5.0.4
  • 4.9.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict REST API access to trusted operators only and monitor for unusual DNS record configurations that could trigger this issue. Avoid using the LMDB backend if possible or implement additional validation on DNS record data submitted via the REST API.

Description

An operator allowed to use the REST API can cause the Authoritative server to produce invalid HTTPS or SVCB record data, which can in turn cause LMDB database corruption, if using the LMDB backend.

References

Community reviews

Loading reviews…