Skip to main content
VulnerabilityPublished

CVE-2026-33632: craigjbass clearancekit · Missing Authorization

Affects craigjbass clearancekitSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.4 High : upgrade to 4.2.4 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.4
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:L/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade clearancekit and craigjbass/clearancekit to 4.2.4.

Affected software

ProductAffectedFixed in
craigjbassclearancekitAffected
  • <4.2.4
Fixed in
  • 4.2.4
GitHubcraigjbass/clearancekitpkg:github/craigjbass/clearancekitOther threatsAffected
  • <4.2.4
Fixed in
  • 4.2.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade ClearanceKit to version 4.2.4 or later, which includes the fix for this vulnerability. After upgrading, it is necessary to reactivate the ClearanceKit system extension to ensure the new event types are properly intercepted and enforced. No other mitigation actions are indicated by the vendor advisory.

Description

CVE-2026-33632 is a high-severity vulnerability in ClearanceKit versions prior to 4.2.4 on macOS. The vulnerability arises because two file operation event types, ES_EVENT_TYPE_AUTH_EXCHANGEDATA and ES_EVENT_TYPE_AUTH_CLONE, were not intercepted by ClearanceKit's opfilter system extension. This omission allows local processes to bypass the file access policies enforced by ClearanceKit. The issue is addressed in version 4.2.4 by subscribing to these event types and routing them through the policy evaluator. Users must upgrade to version 4.2.

References

Community reviews

Loading reviews…