Skip to main content
VulnerabilityPublished

CVE-2026-33638: lin-snow Ech0 · Missing Authorization

Affects lin-snow Ech0Source CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.3 Medium : upgrade to 4.2.0 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Ech0 and lin-snow/Ech0 to 4.2.0.

Affected software

ProductAffectedFixed in
lin-snowEch0Affected
  • <4.2.0
Fixed in
  • 4.2.0
GitHublin-snow/Ech0pkg:github/lin-snow/Ech0Other threatsAffected
  • <4.2.0
Fixed in
  • 4.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Ech0 to version 4.2.0 or later, where the GET /api/allusers endpoint is properly secured with authorization checks. This official fix eliminates the unauthorized user enumeration risk.

Description

CVE-2026-33638 is a medium severity vulnerability in lin-snow Ech0 versions prior to 4.2.0. The issue is a missing authorization check on the GET /api/allusers endpoint, which is publicly accessible and returns user profile metadata without requiring authentication. This allows unauthenticated remote attackers to enumerate users and access their profile information. A fix addressing this issue is available in version 4.2.0.

References

Community reviews

Loading reviews…