Skip to main content
VulnerabilityPublished Updated

CVE-2026-33660: n8n · Code Injection

Affects n8nSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.4 Critical : upgrade to 2.13.3 or 1.123.27 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.13.3, 1.123.27
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 25 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade n8n to 2.13.3 or 1.123.27; n8n-io/n8n to 1.123.27.

Affected software

ProductAffectedFixed in
n8n-ion8nAffected
  • <1.123.27
  • >=2.0.0-rc.0 <2.13.3
  • =2.14.0
Fixed in
  • 2.13.3
  • 1.123.27
npmn8n-io/n8npkg:npm/n8n-io/n8nOther threatsAffected
  • <1.123.27
  • =2.14.0
Fixed in
  • 1.123.27

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in n8n versions 2.14.1, 2.13.3, and 1.123.26. Users should upgrade to one of these versions or later to fully remediate the vulnerability. If immediate upgrade is not possible, administrators should restrict workflow creation and editing permissions to fully trusted users and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These temporary mitigations do not fully eliminate the risk and should only be used short-term until patching is performed.

Description

CVE-2026-33660 is a critical code injection vulnerability in the n8n workflow automation platform prior to versions 2.14.1, 2.13.3, and 1.123.26. An authenticated user with permission to create or modify workflows can exploit the Merge node's "Combine by SQL" mode to read local files and achieve remote code execution due to insufficient sandboxing of SQL statements. The vulnerability has been fixed in the specified versions. Temporary mitigations include restricting workflow creation/editing permissions to trusted users and disabling the Merge node, but these do not fully eliminate the risk.

References

Community reviews

Loading reviews…