CVE-2026-33665: n8n · Improper Authentication
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.4.0 or 1.121.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.0, 1.121.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:LExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade n8n to 2.4.0 or 1.121.0; n8n-io/n8n to 1.121.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in n8n versions 2.4.0 and 1.121.0; users should upgrade to one of these versions or later to remediate the vulnerability. If immediate upgrading is not possible, temporary mitigations include disabling LDAP authentication until the upgrade can be performed, restricting LDAP directory permissions to prevent users from modifying their own email attributes, and auditing existing LDAP-linked accounts for unexpected or unauthorized account associations. These temporary mitigations do not fully resolve the risk and should only be used as short-term measures.
Description
n8n versions prior to 2.4.0 and 1.121.0 contain an improper authentication vulnerability when LDAP authentication is enabled. An authenticated LDAP user who can modify their own LDAP email attribute could impersonate another user, including administrators, by matching their email, resulting in permanent account takeover. This occurs because n8n automatically links LDAP identities to existing local accounts based on email attribute matching, and the linkage persists even if the LDAP email is reverted. The vulnerability requires LDAP authentication to be configured and active. It has been fixed in n8n versions 2.4.