Skip to main content
VulnerabilityPublished Updated

CVE-2026-33693: LemmyNet lemmy · Server-Side Request Forgery (SSRF)

Affects LemmyNet lemmySource CVE Database V5

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 6.5 Medium : upgrade to 0.7.0-beta.9 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.7.0-beta.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade LemmyNet lemmy to 0.7.0-beta.9.

Affected software

ProductAffectedFixed in
LemmyNetlemmyAffected
  • <0.7.0-beta.9
Fixed in
  • 0.7.0-beta.9
crates.iogithub/LemmyNet/lemmypkg:cargo/github/LemmyNet/lemmyOther threatsAffected
  • =0.7.0-beta.9
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Lemmy to version 0.7.0-beta.9 or later, where the vulnerability is patched. Since this is not a cloud service, users must apply the update themselves. Patch status is confirmed by the vendor's versioning information. No additional mitigations are specified or required beyond applying the official fix.

Description

Lemmy is a link aggregator and forum for the fediverse. Prior to version 0.7.0-beta.9, the `v4_is_invalid()` function in `activitypub-federation-rust` (`src/utils.rs`) does not check for `Ipv4Addr::UNSPECIFIED` (0.0.0.0). An unauthenticated attacker controlling a remote domain can point it to 0.0.0.0, bypass the SSRF protection introduced by the fix for CVE-2025-25194 (GHSA-7723-35v7-qcxw), and reach localhost services on the target server. Version 0.7.0-beta.9 patches the issue.

References

Community reviews

Loading reviews…