Skip to main content
VulnerabilityPublished

CVE-2026-33715: chamilo-lms · Missing Authentication

Affects chamilo-lmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.2 High : upgrade to 2.0-RC.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0-RC.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade chamilo-lms to 2.0-RC.3.

Affected software

ProductAffectedFixed in
chamilochamilo-lmsAffected
  • >=2.0-RC.2 <2.0-RC.3
Fixed in
  • 2.0-RC.3
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threatsAffected
  • =2.0.0-RC
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Chamilo LMS to version 2.0.0-RC.3 or later, where this vulnerability has been fixed. Since this is a self-hosted product, administrators should apply the official patch by updating to the fixed version. No other vendor-provided mitigations or temporary fixes are indicated. Patch status is confirmed by the vendor advisory stating the fix is included in version 2.0.0-RC.3.

Description

Chamilo LMS version 2.0-RC.2 contains a vulnerability where a critical AJAX endpoint (install.ajax.php) is accessible without authentication. This endpoint's test_mailer action accepts arbitrary SMTP server details from unauthenticated POST requests, enabling Server-Side Request Forgery (SSRF) and abuse as an open email relay. This can lead to phishing and spam campaigns originating from the server and may disclose internal network information through error messages. The issue is fixed in version 2.0.0-RC.

References

Community reviews

Loading reviews…