CVE-2026-33722: n8n · Incorrect Authorization
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 7.3 High : upgrade to 2.6.4 or 1.123.23 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.6.4, 1.123.23
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade n8n to 2.6.4 or 1.123.23; n8n-io/n8n to 1.123.23.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in n8n versions 1.123.23 and 2.6.4; users should upgrade to these versions or later to remediate the vulnerability. If immediate upgrade is not possible, administrators should restrict n8n access to fully trusted users and/or disable the external secrets integration as temporary mitigations. These workarounds do not fully eliminate the risk and should only be used short-term until patching is performed.
Description
n8n versions prior to 1.123.23 and 2.6.4 contain an authorization bypass vulnerability that allows authenticated users without the externalSecret:list permission to retrieve plaintext secrets from connected external vaults by referencing the secret name in credentials. This vulnerability requires the instance to have an external secrets vault configured and the attacker to know or guess the secret's name. The issue has been fixed in versions 1.123.23 and 2.6.