Skip to main content
VulnerabilityPublished Updated

CVE-2026-33765: pi-hole web · OS Command Injection

Affects pi-hole webSource CVE Database V5

0
Compare

Public exploit available · CVSS 8.9 High : upgrade to 6.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.3% chance of exploitation in 30 days – higher than 70% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade web and pi-hole/web to 6.0.

Affected software

ProductAffectedFixed in
pi-holewebAffected
  • <6.0
Fixed in
  • 6.0
GitHubpi-hole/webpkg:github/pi-hole/webOther threatsAffected
  • <6.0
Fixed in
  • 6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Pi-hole to version 6.0 or later, where this vulnerability is patched. Versions prior to 6.0 are vulnerable and should be updated promptly. Since this is not a cloud service, remediation requires applying the official patch by upgrading the software.

Description

Pi-hole Admin Interface is a web interface for managing Pi-hole, a network-level ad and internet tracker blocking application. Versions prior to 6.0 have a critical OS Command Injection vulnerability in the savesettings.php file. The application takes the user-controlled $_POST['webtheme'] parameter and concatenates it directly into a system command executed via PHP's exec() function. Since the input is neither sanitized nor validated before being passed to the shell, an attacker can append arbitrary system commands to the intended pihole command. Furthermore, because the command is executed with sudo privileges, the injected commands will run with elevated (likely root) privileges. Version 6.0 patches the issue.

References

Community reviews

Loading reviews…