Skip to main content
VulnerabilityPublished Updated

CVE-2026-33942: saloonphp saloon · Deserialization of Untrusted Data

Affects saloonphp saloonSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.1 High : upgrade to 4.0.0 soon.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 4.0 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade saloon and saloonphp/saloon to 4.0.0.

Affected software

ProductAffectedFixed in
saloonphpsaloonAffected
  • <4.0.0
Fixed in
  • 4.0.0
Packagistsaloonphp/saloonpkg:composer/saloonphp/saloonOther threatsAffected
  • <4.0.0
Fixed in
  • 4.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in saloonphp saloon version 4.0.0, which removes unsafe PHP serialization from the AccessTokenAuthenticator class. Users should upgrade to version 4.0.0 or later to remediate this vulnerability. There are no vendor advisories indicating alternative mitigations or that no action is required.

Description

CVE-2026-33942 is a high-severity vulnerability in the saloonphp saloon PHP library versions prior to 4.0.0. It involves unsafe deserialization of untrusted data in the AccessTokenAuthenticator::unserialize() method, which uses PHP's unserialize() with allowed_classes set to true. An attacker controlling the serialized input can inject malicious objects that trigger PHP magic methods, potentially leading to remote code execution when combined with common dependencies like Monolog. The vulnerability is fixed in version 4.0.0 by removing PHP serialization from the affected class.

References

Community reviews

Loading reviews…