CVE-2026-34065: nimiq-primitives · Unchecked Return Value
Affects nimiq-primitivesSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.3.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 31% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.3.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 22 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade nimiq-primitives and github/nimiq/nimiq-primitives to 1.3.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| nimiqnimiq-primitives | Affected
| Fixed in
|
crates.iogithub/nimiq/nimiq-primitivespkg:cargo/github/nimiq/nimiq-primitivesOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to nimiq-primitives version 1.3.0 or later, which includes the patch that properly handles invalid compressed BLS voting keys and prevents node panics. No workarounds are available. Since this is not a cloud service, users must apply the update themselves.
Description
A vulnerability in nimiq-primitives versions prior to 1.3.0 allows an untrusted peer to cause a node to panic by sending an election macro block with an invalid compressed BLS voting key. This occurs because the code does not properly handle errors when uncompressing the voting key, leading to a panic and denial of service. The issue is fixed in version 1.3.0. No known workarounds exist.
References
- github.com/nimiq/core-rs-albatross/security/advisories/GHSA-7c4j-2m43-2mgh (opens in a new tab)
- github.com/nimiq/core-rs-albatross/pull/3662 (opens in a new tab)
- github.com/nimiq/core-rs-albatross/commit/e10eaebcd7774e5da6d0ff5e88ed13503474f0ff (opens in a new tab)
- github.com/nimiq/core-rs-albatross/releases/tag/v1.3.0 (opens in a new tab)