Skip to main content
VulnerabilityPublished

CVE-2026-34067: nimiq-transaction · Reachable Assertion

Affects nimiq-transactionSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.1 Low : upgrade to 1.3.0 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nimiq-transaction and nimiq/nimiq-transaction to 1.3.0.

Affected software

ProductAffectedFixed in
nimiqnimiq-transactionAffected
  • <1.3.0
Fixed in
  • 1.3.0
crates.ionimiq/nimiq-transactionpkg:cargo/nimiq/nimiq-transactionOther threatsAffected
  • <1.3.0
Fixed in
  • 1.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to nimiq-transaction version 1.3.0 or later, where the assertion panic is fixed. No known workarounds exist. Since this is a library vulnerability, ensure that all dependent software using nimiq-transaction is updated accordingly.

Description

CVE-2026-34067 is a low-severity vulnerability in the nimiq-transaction Rust library used by Nimiq. Before version 1.3.0, the function HistoryTreeProof::verify contains an assertion that panics if a malformed proof has mismatched lengths between history and positions arrays. Since the proof data is attacker-controlled from untrusted peer-to-peer network responses, a malicious actor could cause the application to crash by sending a crafted proof with length mismatch. The issue is fixed in version 1.3.0. No workarounds are known.

References

Community reviews

Loading reviews…