Skip to main content
VulnerabilityPublished

CVE-2026-34160: chamilo-lms · Missing Authentication

Affects chamilo-lmsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.6 High : upgrade to 2.0-RC.3 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.0-RC.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade chamilo-lms to 2.0-RC.3.

Affected software

ProductAffectedFixed in
chamilochamilo-lmsAffected
  • <2.0-RC.3
Fixed in
  • 2.0-RC.3
GitHubchamilo/chamilo-lmspkg:github/chamilo/chamilo-lmsOther threatsAffected
  • =2.0.0-RC.3
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Chamilo LMS version 2.0.0-RC.3. Users should upgrade to this version or later to remediate the vulnerability. Until upgraded, restrict access to the vulnerable endpoint and monitor for suspicious activity related to SSRF attempts. Patch status is confirmed by the vendor's version release notes indicating the issue is fixed in 2.0.0-RC.3.

Description

Chamilo LMS versions prior to 2.0.0-RC.3 contain an unauthenticated Server-Side Request Forgery (SSRF) vulnerability in the PENS plugin endpoint. This endpoint accepts a user-controlled URL parameter that the server fetches without filtering internal or private IP addresses. Exploitation allows attackers to probe internal network services, access cloud metadata endpoints to steal credentials, or trigger state-changing operations on internal services without authentication. The issue has been fixed in version 2.0.0-RC.3.

References

Community reviews

Loading reviews…