Skip to main content
VulnerabilityPublished

CVE-2026-34176: F5 BIG-IP · OS Command Injection

Affects F5 BIG-IPSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High · fixed in 21.0.0.2 : patch F5 BIG-IP soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 21.0.0.2, 17.5.1.6, 17.1.3.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade F5 BIG-IP to 21.0.0.2, 17.5.1.6 or 17.1.3.2.

Affected software

ProductAffectedFixed in
F5BIG-IPAffected
  • >=21.0.0 <21.0.0.2
  • >=17.5.0 <17.5.1.6
  • >=17.1.0 <17.1.3.2
  • >=16.1.0
Fixed in
  • 21.0.0.2
  • 17.5.1.6
  • 17.1.3.2

AI-suggested

Restrict authenticated access to the iControl REST interface to trusted administrators only and consider additional network-level controls to limit exposure until a patch is available.

Description

CVE-2026-34176 is a high-severity vulnerability in F5 BIG-IP appliances running in Appliance mode. It involves an authenticated remote OS command injection via an undisclosed iControl REST endpoint. Successful exploitation allows an attacker with high privileges to cross security boundaries, potentially leading to full compromise of confidentiality and integrity without impacting availability. The vulnerability affects specific versions including 21.0.0, 17.5.0, 17.1.0, and 16.

References

Community reviews

Loading reviews…