Skip to main content
VulnerabilityPublished

CVE-2026-34179: Canonical lxd · Mass Assignment

Affects Canonical lxdSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical · fixed in 6.8.0 : patch Canonical lxd as a priority.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.8.0, 5.21.5, 5.0.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Canonical lxd to 6.8.0, 5.21.5 or 5.0.7.

Affected software

ProductAffectedFixed in
CanonicallxdAffected
  • >=6.0.0 <6.8.0
Fixed in
  • 6.8.0
CanonicallxdAffected
  • >=5.1.0 <5.21.5
Fixed in
  • 5.21.5
CanonicallxdAffected
  • >=4.12.0 <5.0.7
Fixed in
  • 5.0.7
GitHubcanonical/lxdpkg:github/canonical/lxdOther threatsAffected
  • =4.12.0
  • =5.1.0
  • =6.0.0
Fixed in–
GitHublxdpkg:github/lxdOther threatsAffected
  • >=4.12.0 <5.0.7
  • >=5.1.0 <5.21.5
  • >=6.0.0 <6.8.0
Fixed in
  • 5.0.7
  • 5.21.5
  • 6.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to the /1.0/certificates/{fingerprint} endpoint to trusted users only and monitor for suspicious certificate update activities. Avoid granting unnecessary TLS certificate user privileges to reduce risk.

Description

CVE-2026-34179 is a critical vulnerability in Canonical LXD versions 4.12 through 6.7 where the doCertificateUpdate function fails to validate the Type field in certificate update requests. This flaw allows a remote authenticated attacker with restricted TLS certificate user privileges to escalate their privileges to cluster admin. The vulnerability has a CVSS score of 9.1, indicating a high severity with network attack vector, low attack complexity, and no user interaction required. There are no known exploits in the wild at this time.

References

Community reviews

Loading reviews…