Skip to main content
VulnerabilityPublished

CVE-2026-34500: Apache Tomcat · Improper Authentication

Affects Apache TomcatSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 10.1.54 or 9.0.117 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.1.54, 9.0.117
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat/tomcat to 10.1.54 or 9.0.117.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache TomcatAffected
  • >=11.0.0-M14 <=11.0.20
  • >=10.1.22 <=10.1.53
  • >=9.0.92 <=9.0.116
Fixed in–
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • >=10.1.22 <10.1.54
  • >=9.0.92 <9.0.117
Fixed in
  • 10.1.54
  • 9.0.117

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat instances to versions 11.0.21, 10.1.54, or 9.0.117 where the issue is fixed. Patch status is confirmed by the vendor's recommended upgrade versions. No additional mitigation steps are indicated.

Description

CLIENT_CERT authentication does not fail as expected for some scenarios when soft fail is disabled and FFM is used in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.20, from 10.1.22 through 10.1.53, from 9.0.92 through 9.0.116. Users are recommended to upgrade to version 11.0.21, 10.1.54 or 9.0.117, which fixes the issue.

References

Community reviews

Loading reviews…