Skip to main content
CVE-2026-34559VulnerabilityPublished

CVE-2026-34559: ci4-cms-erp ci4ms · Cross-site Scripting

Affects ci4-cms-erp ci4msSource CVE Database V5

0

Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.31.0.0 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.0.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to ci4ms version 0.31.0.0 or later, where the vulnerability has been patched. No other mitigations are specified or required once the official fix is applied.

Description

CI4MS, a CodeIgniter 4-based CMS, contained a stored cross-site scripting (XSS) vulnerability in versions prior to 0.31.0.0. The vulnerability arises from improper sanitization of user input in the blog tag name field, allowing attackers to inject malicious JavaScript payloads. These payloads are stored server-side and rendered unsafely on public and administrative tag pages without proper output encoding. This issue has been addressed and patched in version 0.31.0.0.

References

Community reviews

Loading reviews…