Skip to main content
VulnerabilityPublished

CVE-2026-34567: ci4-cms-erp ci4ms · Cross-site Scripting

Affects ci4-cms-erp ci4msSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.31.0.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.

Contested

Critical score, yet low EPSS after six months
EPSS
0.2% chance of exploitation in 30 days – higher than 19% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.31.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.0.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <0.31.0.0
Fixed in
  • 0.31.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade ci4ms to version 0.31.0.0 or later, where this vulnerability has been patched. No other mitigation is required as the fix addresses the root cause by properly sanitizing and encoding user input in the Categories section.

Description

CVE-2026-34567 is a critical stored cross-site scripting (XSS) vulnerability in the ci4ms application, a CodeIgniter 4-based CMS skeleton. Versions prior to 0.31.0.0 do not properly sanitize user input when creating or editing blog post categories, allowing attackers to inject malicious JavaScript payloads. These payloads are stored server-side and rendered unsafely when categories are viewed, leading to potential compromise of confidentiality, integrity, and availability. The issue has been patched in version 0.31.0.0.

References

Community reviews

Loading reviews…