CVE-2026-34572: ci4-cms-erp ci4ms · Improper Access Control
Affects ci4-cms-erp ci4msSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 0.31.0.0 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.31.0.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 1 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade ci4ms and ci4-cms-erp/ci4ms to 0.31.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ci4-cms-erpci4ms | Affected
| Fixed in
|
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to ci4ms version 0.31.0.0 or later, where this issue has been patched. The fix ensures that active sessions are revoked immediately upon account deactivation, enforcing proper access control. Until upgrading, consider manual session invalidation mechanisms if possible. Patch status is confirmed fixed in the official release.
Description
CI4MS, a CodeIgniter 4-based CMS skeleton, had a critical improper access control vulnerability prior to version 0.31.0.0. The application did not revoke active user sessions immediately when an account was deactivated, allowing users with deactivated accounts to maintain access indefinitely until manual logout. This flaw arises because account state changes are only enforced during login, not for existing sessions, and there is no session expiration mechanism. The vulnerability breaks the intended access control policy and can lead to persistent unauthorized access. This issue has been fixed in version 0.31.0.