CVE-2026-34574: parse-server · Incorrect Comparison
Affects parse-serverSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 9.7.0-alpha.14 or 8.6.69 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 12% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.7.0-alpha.14, 8.6.69
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Mar 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade parse-server to 9.7.0-alpha.14 or 8.6.69; parse-community/parse-server to 8.6.69.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| parse-communityparse-server | Affected
| Fixed in
|
| parse-communityparse-server | Affected
| Fixed in
|
npmparse-community/parse-serverpkg:npm/parse-community/parse-serverOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade parse-server to version 8.6.69 or later, or to 9.7.0-alpha.14 or later. These versions include the official fix that prevents null values from bypassing immutability guards on session fields. No other mitigation is indicated.
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.69 and 9.7.0-alpha.14, an authenticated user can bypass the immutability guard on session fields (expiresAt, createdWith) by sending a null value in a PUT request to the session update endpoint. This allows nullifying the session expiry, making the session valid indefinitely and bypassing configured session length policies. This issue has been patched in versions 8.6.69 and 9.7.0-alpha.14.
References
- github.com/parse-community/parse-server/security/advisories/GHSA-f6j3-w9v3-cq22 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10347 (opens in a new tab)
- github.com/parse-community/parse-server/pull/10348 (opens in a new tab)
- github.com/parse-community/parse-server/commit/90802969fc713b7bc9733d7255c7519a6ed75d21 (opens in a new tab)
- github.com/parse-community/parse-server/commit/ebccd7fe2708007e62f705ee1c820a6766178777 (opens in a new tab)