Skip to main content
VulnerabilityPublished

CVE-2026-34729: thorsten phpMyFAQ · Cross-site Scripting

Affects thorsten phpMyFAQSource CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium : upgrade to 4.1.1 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.1.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade phpMyFAQ and thorsten/phpMyFAQ to 4.1.1.

Affected software

ProductAffectedFixed in
thorstenphpMyFAQAffected
  • <4.1.1
Fixed in
  • 4.1.1
GitHubthorsten/phpMyFAQpkg:github/thorsten/phpMyFAQOther threatsAffected
  • <4.1.1
Fixed in
  • 4.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade phpMyFAQ to version 4.1.1 or later, where this vulnerability has been fixed. No other mitigation is necessary as the vendor has provided an official fix.

Description

phpMyFAQ versions prior to 4.1.1 contain a stored cross-site scripting (XSS) vulnerability due to improper neutralization of input in the Filter::removeAttributes() function. This vulnerability allows an attacker with high privileges and user interaction to inject malicious scripts that can compromise confidentiality and integrity. The issue has been addressed in version 4.1.1.

References

Community reviews

Loading reviews…