Skip to main content
VulnerabilityPublished

CVE-2026-34730: copier · Path Traversal

Affects copierSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.5 Medium : upgrade to 9.14.1 when convenient.

Data as of 29 Oct 2026, 19:04 UTC

CVSS 3.1 base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.14.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade copier to 9.14.1.

Affected software

ProductAffectedFixed in
copier-orgcopierAffected
  • <9.14.1
Fixed in
  • 9.14.1
PyPIcopierpkg:pypi/copierOther threatsAffected
  • <9.14.1
Fixed in
  • 9.14.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade copier to version 9.14.1 or later, where this path traversal vulnerability has been fixed. Users relying on untrusted templates should apply this update promptly to prevent unauthorized local file disclosure. No other mitigations are indicated or required once patched.

Description

Copier is a library and CLI app for rendering project templates. Prior to version 9.14.1, Copier's _external_data feature allows a template to load YAML files using template-controlled paths. If untrusted templates are in scope, a malicious template can read attacker-chosen YAML-parseable local files that are accessible to the user running Copier and expose their contents in rendered output. This issue has been patched in version 9.14.1.

References

Community reviews

Loading reviews…