Skip to main content
VulnerabilityPublished

CVE-2026-34746: payloadcms payload · Server-Side Request Forgery (SSRF)

Affects payloadcms payloadSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 7.7 High : upgrade to 3.79.1 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.79.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade payload and payloadcms/payload to 3.79.1.

Affected software

ProductAffectedFixed in
payloadcmspayloadAffected
  • <3.79.1
Fixed in
  • 3.79.1
GitHubpayloadcms/payloadpkg:github/payloadcms/payloadOther threatsAffected
  • <3.79.1
Fixed in
  • 3.79.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade PayloadCMS to version 3.79.1 or later, where this SSRF vulnerability has been patched. No other mitigations are indicated or required once the official fix is applied.

Description

PayloadCMS versions prior to 3.79.1 contain an authenticated Server-Side Request Forgery (SSRF) vulnerability in the upload functionality. Authenticated users with create or update permissions on upload-enabled collections can cause the server to make arbitrary outbound HTTP requests. This vulnerability has been addressed in version 3.79.1. The CVSS score is 7.7, indicating high severity due to the potential for server-side request manipulation without impacting data integrity or availability directly.

References

Community reviews

Loading reviews…