CVE-2026-34753: vllm · Server-Side Request Forgery (SSRF)
Affects vllmSource CVE Database V5
Not known to be exploited · CVSS 5.4 Medium : upgrade to 0.19.0 when convenient.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.19.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade vllm to 0.19.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| vllm-projectvllm | Affected
| Fixed in
|
PyPIvllmpkg:pypi/vllmOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
This vulnerability is fixed in vLLM version 0.19.0. Users should upgrade to version 0.19.0 or later to remediate this issue. There is no indication that temporary mitigations or workarounds are available. Patch status is not explicitly confirmed beyond the fix in version 0.19.0, so users should consult the vendor's official release notes for confirmation.
Description
vLLM versions from 0.16.0 up to but not including 0.19.0 contain a server-side request forgery (SSRF) vulnerability in the download_bytes_from_url function. This flaw allows an attacker who can control batch input JSON to make the vLLM batch runner issue arbitrary HTTP/HTTPS requests from the server without any URL validation or domain restrictions. The vulnerability enables targeting of internal services accessible from the vLLM host, such as cloud metadata endpoints or internal HTTP APIs. The issue is fixed in version 0.19.0.