CVE-2026-34940: kubeai · OS Command Injection
Affects kubeaiSource CVE Database V5
Not known to be exploited · CVSS 8.7 High : upgrade to 0.23.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.23.2
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade kubeai and kubeai-project/kubeai to 0.23.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| kubeai-projectkubeai | Affected
| Fixed in
|
GitHubkubeai-project/kubeaipkg:github/kubeai-project/kubeaiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade KubeAI to version 0.23.2 or later, where this vulnerability is fixed. Patch status is not explicitly confirmed beyond the fix in 0.23.2, so users should verify with the vendor advisory for the latest guidance.
Description
KubeAI versions prior to 0.23.2 contain an OS command injection vulnerability in the ollamaStartupProbeScript() function. This function unsafely constructs shell commands from unsanitized model URL components, which are executed as Kubernetes startup probes. An attacker with permissions to create or update Model custom resources can inject arbitrary shell commands that run inside model server pods. This vulnerability is fixed in version 0.23.2.