Skip to main content
CVE-2026-34989VulnerabilityPublished

CVE-2026-34989: ci4-cms-erp ci4ms · Cross-site Scripting

Affects ci4-cms-erp ci4msSource CVE Database V5

0

Not known to be exploited · CVSS 9.4 Critical : upgrade to 31.0.0.0 as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 4.0 base score
9.4Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 31.0.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade ci4ms and ci4-cms-erp/ci4ms to 31.0.0.0.

Affected software

ProductAffectedFixed in
ci4-cms-erpci4msAffected
  • <31.0.0.0
Fixed in
  • 31.0.0.0
GitHubci4-cms-erp/ci4mspkg:github/ci4-cms-erp/ci4msOther threatsAffected
  • <31.0.0.0
Fixed in
  • 31.0.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to ci4ms version 31.0.0.0 or later, where this vulnerability is fixed. Avoid using affected versions prior to 31.0.0.0. No additional mitigation guidance is provided in the input data.

Description

CI4MS, a CodeIgniter 4-based CMS, contains a stored cross-site scripting (XSS) vulnerability in versions prior to 31.0.0.0. The issue arises because user input for profile names is not properly sanitized or encoded before being stored and rendered, allowing attackers to inject malicious JavaScript payloads. This vulnerability has a critical severity with a CVSS 4.0 score of 9.4. The vulnerability is fixed in version 31.0.

References

Community reviews

Loading reviews…