Skip to main content
VulnerabilityPublished

CVE-2026-35038: signalk-server · Improper Input Validation

Affects signalk-serverSource CVE Database V5

0
Compare

Public exploit available · CVSS 2.1 Low : upgrade to 2.24.0 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 23% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.24.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade signalk-server and signalk/signalk-server to 2.24.0.

Affected software

ProductAffectedFixed in
SignalKsignalk-serverAffected
  • <2.24.0
Fixed in
  • 2.24.0
GitHubsignalk/signalk-serverpkg:github/signalk/signalk-serverOther threatsAffected
  • <2.24.0
Fixed in
  • 2.24.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade SignalK Server to version 2.24.0 or later, where this vulnerability is patched. No other mitigation is required as the issue is resolved by the official fix.

Description

CVE-2026-35038 is a low-severity vulnerability in SignalK Server versions prior to 2.24.0. It involves improper input validation that allows a low-privileged authenticated user to bypass prototype boundary filtering via the 'from' field. This enables the user to read internal functions and properties from the global prototype object, violating data isolation. The vulnerability has been patched in version 2.24.0.

References

Community reviews

Loading reviews…