CVE-2026-35050: oobabooga text-generation-webui · Path Traversal
Affects oobabooga text-generation-webuiSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.1.1 as a priority.
Data as of 30 Oct 2026, 11:52 UTC
Contested
Critical score, yet low EPSS after six months- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.1.1
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade text-generation-webui and oobabooga/text-generation-webui to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| oobaboogatext-generation-webui | Affected
| Fixed in
|
GitHuboobabooga/text-generation-webuipkg:github/oobabooga/text-generation-webuiOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade oobabooga text-generation-webui to version 4.1.1 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated in the available data.
Description
CVE-2026-35050 is a critical path traversal vulnerability in oobabooga's text-generation-webui versions prior to 4.1.1. It allows users to save extension settings as Python files in the application root directory, potentially overwriting existing Python files such as download-model.py. This overwritten file can then be executed via the Model menu to download a new model, enabling arbitrary code execution. The vulnerability is fixed in version 4.1.1.