Skip to main content
VulnerabilityPublished Updated

CVE-2026-35069: Dell PowerFlex · SQL Injection

Affects Dell PowerFlexSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 5.7 Medium : upgrade to 5.1.0.1 or later or 4.5.5.2 or later when convenient.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
5.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 13% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.0.1 or later, 4.5.5.2 or later
CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Dell PowerFlex to 5.1.0.1 or later or 4.5.5.2 or later.

Affected software

ProductAffectedFixed in
DellPowerFlexAffected
  • =0
Fixed in
  • 5.1.0.1 or later
  • 4.5.5.2 or later

AI-suggested

If you cannot patch yet, restrict adjacent network access to the affected Dell PowerFlex Manager instances and monitor for unusual activity related to SQL injection attempts.

Description

Dell PowerFlex Manager, version(s) prior to 5.1.0.1, contain(s) an Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability. A low privileged attacker with adjacent network access could potentially exploit this vulnerability, leading to Script injection.

References

Community reviews

Loading reviews…