Skip to main content
VulnerabilityPublished

CVE-2026-35086: Apache OFBiz · Code Injection

Affects Apache OFBizSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 24.09.06 when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 24.09.06
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 19 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Apache OFBiz and org.apache.ofbiz/ofbiz to 24.09.06.

Affected software

ProductAffectedFixed in
Apache Software FoundationApache OFBizAffected
  • <24.09.06
Fixed in
  • 24.09.06
Mavenorg.apache.ofbiz/ofbizpkg:maven/org.apache.ofbiz/ofbizOther threatsAffected
  • <24.09.06
Fixed in
  • 24.09.06

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache OFBiz to version 24.09.06 or later, which contains the fix for this vulnerability. Patch status is confirmed by the vendor advisory recommending this upgrade. No other mitigation steps are specified.

Description

CVE-2026-35086 is a medium severity vulnerability in Apache OFBiz affecting its email services. It involves improper control of code generation, classified as a code injection issue (CWE-94). The vulnerability exists in versions before 24.09.06. Users are advised to upgrade to version 24.09.06 where the issue is fixed. The CVSS score is 6.5, indicating a network exploitable vulnerability with low impact on confidentiality and integrity and no impact on availability.

References

Community reviews

Loading reviews…