CVE-2025-54466: Apache OFBiz · Code Injection
Affects Apache OFBizSource CVE Database V5
Not known to be exploited · 26% EPSS · CVSS 6.3 Medium · fixed in 24.09.02 : update Apache OFBiz when convenient.
Data as of 26 Oct 2026, 12:55 UTC
- EPSS
- 26.5% chance of exploitation in 30 days – higher than 97% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 24.09.02
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 15 Aug 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software Foundation Apache OFBiz | Affected
| Fixed in– |
AI-suggested
To mitigate this vulnerability, organizations should immediately upgrade Apache OFBiz to version 24.09.02 or later, which contains the official fix. If upgrading is not immediately possible, disable the scrum plugin to eliminate the attack surface. Additionally, implement network-level protections such as web application firewalls (WAFs) to detect and block suspicious requests targeting the scrum plugin endpoints. Monitor logs for unusual activity related to the scrum plugin and conduct regular vulnerability scans to identify any exposure. Employ strict access controls and segmentation to limit the impact of a potential compromise. Educate users about the risk of interacting with untrusted content that could trigger the vulnerability. Finally, maintain an incident response plan ready to address any exploitation attempts promptly.
Description
Improper Control of Generation of Code ('Code Injection') vulnerability leading to a possible RCE in Apache OFBiz scrum plugin. This issue affects Apache OFBiz: before 24.09.02 only when the scrum plugin is used. Even unauthenticated attackers can exploit this vulnerability. Users are recommended to upgrade to version 24.09.02, which fixes the issue.
References
- ofbiz.apache.org/download.html (opens in a new tab)
- ofbiz.apache.org/security.html (opens in a new tab)
- ofbiz.apache.org/release-notes-24.09.02.html (opens in a new tab)
- issues.apache.org/jira/browse/OFBIZ-13276 (opens in a new tab)
- lists.apache.org/thread/14d0yd9co9gx2mctd3vyz1cc8d39n915 (opens in a new tab)
- openwall.com/lists/oss-security/2025/08/05/1 (opens in a new tab)