CVE-2026-35168: devcode-it openstamanager · SQL Injection
Affects devcode-it openstamanagerSource CVE Database V5
Not known to be exploited · CVSS 8.8 High : upgrade to 2.10.2 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 51% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade openstamanager and devcode-it/openstamanager to 2.10.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| devcode-itopenstamanager | Affected
| Fixed in
|
GitHubdevcode-it/openstamanagerpkg:github/devcode-it/openstamanagerOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch fixing this vulnerability is available in OpenSTAManager version 2.10.2. Users should upgrade to version 2.10.2 or later to remediate this issue. Since this is not a cloud service, remediation requires applying the official software update. No vendor advisory content contradicts this; therefore, upgrading is the recommended mitigation.
Description
OpenSTAManager versions prior to 2.10.2 contain a SQL injection vulnerability in the Aggiornamenti (Updates) module. This module accepts a JSON array of SQL statements via POST and executes them directly on the database without validation or sanitization. An authenticated user with access to this module can execute arbitrary SQL commands, including destructive operations like DROP or ALTER. The vulnerability disables foreign key checks before execution, increasing the risk of database integrity compromise. This issue is patched in version 2.10.2.