Skip to main content
VulnerabilityPublished Updated

CVE-2026-35192: djangoproject Django · Use of Persistent Cookies Containing Sensitive Information

Affects djangoproject DjangoSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 2.3 Low : upgrade to 6.0.5 or 5.2.14 when convenient.

Data as of 2 Nov 2026, 22:58 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.0.5, 5.2.14
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Django and django to 6.0.5 or 5.2.14.

Affected software

ProductAffectedFixed in
djangoprojectDjangoAffected
  • >=6.0 <6.0.5
Fixed in
  • 6.0.5
djangoprojectDjangoAffected
  • >=5.2 <5.2.14
Fixed in
  • 5.2.14
PyPIdjangopkg:pypi/djangoOther threatsAffected
  • =5.2
  • =6.0
Fixed in–
PyPIdjangopkg:pypi/djangoOther threatsAffected
  • >=6.0 <6.0.5
  • >=5.2 <5.2.14
Fixed in
  • 6.0.5
  • 5.2.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should verify if they are running affected versions and consider upgrading to Django 6.0.5 or 5.2.14 or later once patches are officially released. As a temporary measure, disabling SESSION_SAVE_EVERY_REQUEST may reduce exposure.

Description

A vulnerability in Django versions 6.0 before 6.0.5 and 5.2 before 5.2.14 allows a remote attacker to steal a user's session if the user visits a cached public page and the SESSION_SAVE_EVERY_REQUEST setting is enabled. The issue arises because response headers do not vary on cookies when the session is unmodified, potentially exposing persistent cookies containing sensitive information. Earlier unsupported Django versions may also be affected. The CVSS score is low (2.

References

Community reviews

Loading reviews…