CVE-2026-35194: Apache Flink · Code Injection
Affects Apache FlinkSource CVE Database V5
Not known to be exploited · CVSS 8.1 High : upgrade to 1.20.4 soon.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.20.4, 2.2.1, 2.1.2 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 15 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Apache Flink to 1.20.4; org.apache.flink/flink to 2.2.1, 2.1.2 or 2.0.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache Flink | Affected
| Fixed in
|
Mavenorg.apache.flink/flinkpkg:maven/org.apache.flink/flinkOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Flink to one of the fixed versions: 1.20.4, 2.0.2, 2.1.2, or 2.2.1. These versions contain the official fixes for this vulnerability. No other mitigation or temporary workaround is indicated in the provided data. Patch status is confirmed by the vendor advisory recommending these upgrades.
Description
Code injection in SQL code generation in Apache Flink 1.15.0 through 1.20.x and 2.0.0 through 2.x allows authenticated users with query submission privileges to execute arbitrary code on TaskManagers via maliciously crafted SQL queries. The vulnerability affects JSON functions (1.15.0+) and LIKE expressions with ESCAPE clauses (1.17.0+). User-controlled strings are interpolated into generated Java code without proper escaping, allowing attackers to break out of string literals and inject arbitrary expressions. Users are recommended to upgrade to either version 1.20.4, 2.0.2, 2.1.2 or 2.2.1, which fixes this issue.