Skip to main content
VulnerabilityPublished

CVE-2026-35366: Uutils coreutils · Unchecked Error Condition

Affects Uutils coreutilsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 4.4 Medium : upgrade to 0.6.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Uutils coreutils to 0.6.0.

Affected software

ProductAffectedFixed in
UutilscoreutilsAffected
  • <0.6.0
Fixed in
  • 0.6.0
GitHubuutils/coreutilspkg:github/uutils/coreutilsOther threatsAffected
  • =0
Fixed in–
GitHubcoreutilspkg:github/coreutilsOther threatsAffected
  • <0.6.0
Fixed in
  • 0.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, administrators should be aware that printenv may not show all environment variables if they contain invalid UTF-8 sequences. Alternative inspection methods that do not rely on UTF-8 validation should be used to detect suspicious environment variables.

Description

The printenv utility in uutils coreutils does not display environment variables containing invalid UTF-8 byte sequences, silently skipping them instead. This behavior deviates from POSIX standards, which allow arbitrary bytes in environment strings. As a result, malicious environment variables with invalid UTF-8 can evade inspection by administrators or security tools, potentially hiding attacks such as library injection. The vulnerability affects version 0 of uutils coreutils and has a medium severity rating with a CVSS score of 4.4.

References

Community reviews

Loading reviews…