Skip to main content
VulnerabilityPublished

CVE-2026-41679: paperclipai paperclip · Improper Authentication

Affects paperclipai paperclipSource CVE Database V5

0
Compare

Exploited in the wild · public exploit available (Metasploit) · 31% EPSS : upgrade to 2026.410.0 now.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
31.6% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.410.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Apr 2026

  2. Weaponized: evidence found.

    1 Metasploit module

  3. Exploited in the wild: evidence found.

    Exploited per ENISA EUVD 116 days after disclosure

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), ENISA EUVD, the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade paperclip and @paperclipai/server to 2026.410.0.

Affected software

ProductAffectedFixed in
paperclipaipaperclipAffected
  • <2026.410.0
Fixed in
  • 2026.410.0
paperclipai@paperclipai/serverAffected
  • <2026.410.0
Fixed in
  • 2026.410.0

AI-suggested

Upgrade Paperclip to version 2026.416.0 or later, which patches this vulnerability. Since the vendor advisory indicates the issue is fixed in this version, applying this official update fully mitigates the risk. Patch status is confirmed by the version information in the description. No additional mitigations are specified.

Description

CVE-2026-41679 is a critical improper authentication vulnerability in Paperclip, a Node.js server and React UI platform for orchestrating AI agents. Prior to version 2026.416.0, an unauthenticated attacker can remotely execute arbitrary code on any network-accessible Paperclip instance running in authenticated mode with default configuration. The attack requires no user interaction or credentials and involves a chain of six API calls. The vulnerability is patched in version 2026.416.0.

References

Community reviews

Loading reviews…