Skip to main content
VulnerabilityPublished

CVE-2026-35379: Uutils coreutils · Incorrect Provision of Specified Functionality

Affects Uutils coreutilsSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 3.3 Low : upgrade to 0.8.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
3.3Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 4% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.8.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Uutils coreutils to 0.8.0.

Affected software

ProductAffectedFixed in
UutilscoreutilsAffected
  • <0.8.0
Fixed in
  • 0.8.0
GitHubuutils/coreutilspkg:github/uutils/coreutilsOther threatsAffected
  • =0
Fixed in–
GitHubcoreutilspkg:github/coreutilsOther threatsAffected
  • <0.8.0
Fixed in
  • 0.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, users should be cautious when using the tr utility in uutils coreutils for operations involving [:graph:] and [:print:] character classes. Consider verifying outputs manually or using alternative tools that conform to POSIX standards for character classes.

Description

A logic error in the tr utility of uutils coreutils causes the program to incorrectly define the [:graph:] and [:print:] character classes. The implementation mistakenly includes the ASCII space character (0x20) in the [:graph:] class and excludes it from the [:print:] class, effectively reversing the standard behavior established by POSIX and GNU coreutils. This vulnerability leads to unintended data modification or loss when the utility is used in automated scripts or data-cleaning pipelines that rely on standard character class semantics. For example, a command executed to delete all graphical characters while intending to preserve whitespace will incorrectly delete all ASCII spaces, potentially resulting in data corruption or logic failures in downstream processing.

References

Community reviews

Loading reviews…