CVE-2026-35390: bulwarkmail webmail · Cross-site Scripting
Affects bulwarkmail webmailSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.4.11 when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 5% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.11
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade webmail and bulwarkmail/webmail to 1.4.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| bulwarkmailwebmail | Affected
| Fixed in
|
GitHubbulwarkmail/webmailpkg:github/bulwarkmail/webmailOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Bulwark Webmail to version 1.4.11 or later, where the reverse proxy sets an enforcing Content-Security-Policy header instead of a report-only header, effectively blocking XSS attacks. No other mitigation is indicated or necessary once the update is applied.
Description
Bulwark Webmail versions prior to 1.4.11 have a cross-site scripting (XSS) vulnerability due to the reverse proxy setting a Content-Security-Policy-Report-Only header instead of an enforcing Content-Security-Policy header. This allowed script injection via crafted email HTML, enabling arbitrary JavaScript execution in the application's context. The vulnerability is fixed in version 1.4.11.