Skip to main content
VulnerabilityPublished

CVE-2026-35454: coder code-marketplace · Path Traversal

Affects coder code-marketplaceSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 8.7 High : upgrade to 2.4.2 soon.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 27% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade code-marketplace and coder/code-marketplace to 2.4.2.

Affected software

ProductAffectedFixed in
codercode-marketplaceAffected
  • <2.4.2
Fixed in
  • 2.4.2
GitHubcoder/code-marketplacepkg:github/coder/code-marketplaceOther threatsAffected
  • <2.4.2
Fixed in
  • 2.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in coder/code-marketplace version 2.4.2. Users should upgrade to version 2.4.2 or later to remediate this issue. Patch status is confirmed by the vendor's versioning information. Until upgrade, avoid installing untrusted VSIX extensions.

Description

CVE-2026-35454 is a high-severity path traversal vulnerability in coder/code-marketplace versions prior to 2.4.2. The vulnerability, known as Zip Slip, allows a malicious VSIX file to write arbitrary files outside the intended extension directory. This occurs because the ExtractZip function passes raw zip entry names to a callback that writes files using filepath. Join without properly restricting the resulting path, enabling directory traversal via '.. ' components. The issue is fixed in version 2.4.2.

References

Community reviews

Loading reviews…